[openssl-dev] Errors when loading an OpenSSL RSA Engine

danigrosu dni.grosu at gmail.com
Wed Mar 9 14:45:32 UTC 2016


danigrosu wrote
> I'm just trying to implement an RSA engine and I thought that this would
> be a good start.
> I tryed successfully the 
> MD5 Engine
> <https://www.openssl.org/blog/blog/2015/11/23/engine-building-lesson-2-an-example-md5-engine/>  
>  written by Richard Levitte and my next step is to build an RSA engine
>  which I will use in my application.
> 
> I think my problem is simple and it's just something that I miss.

Relating to the MD5 Engine, I tryed to build the  git version
<https://github.com/engine-corner/Lesson-2-A-digest>   manually with these
commands:
$ gcc -fPIC -o rfc1321/md5c.o -c rfc1321/md5c.c
$ gcc -fPIC -o md5-engine.o -c e_md5.c
$ gcc -shared -o md5-engine.so -lcrypto md5-engine.o rfc1321/md5c.o
... and it failed when I tried to load the engine, but using the autotools
and a few modifications it worked.

So, maybe, the same problem is here, with the RSA-X engine.
Maybe Mr. Levitte could clarify this.

Dani Grosu



--
View this message in context: http://openssl.6102.n7.nabble.com/Errors-when-loading-an-OpenSSL-RSA-Engine-tp64385p64483.html
Sent from the OpenSSL - Dev mailing list archive at Nabble.com.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mta.openssl.org/pipermail/openssl-dev/attachments/20160309/64d42c86/attachment.html>


More information about the openssl-dev mailing list