[openssl-dev] Errors when loading an OpenSSL RSA Engine

Blumenthal, Uri - 0553 - MITLL uri at ll.mit.edu
Wed Mar 9 16:28:59 UTC 2016

> Relating to the MD5 Engine, I tryed to build the git version
> <https://github.com/engine-corner/Lesson-2-A-digest>  manually with these
> commands:
> $ gcc -fPIC -o rfc1321/md5c.o -c rfc1321/md5c.c
> $ gcc -fPIC -o md5-engine.o -c e_md5.c
> $ gcc -shared -o md5-engine.so -lcrypto md5-engine.o rfc1321/md5c.o
> ... and it failed when I tried to load the engine, but using the autotools and
> a few modifications it worked.

When I try autotools, I get this:

git clone https://github.com/engine-corner/Lesson-2-A-digest.git

Cloning into 'Lesson-2-A-digest'...

remote: Counting objects: 21, done.

remote: Total 21 (delta 0), reused 0 (delta 0), pack-reused 21

Unpacking objects: 100% (21/21), done.

Checking connectivity... done.

$ cd Lesson-2-A-digest/

$ autoreconf -i

aclocal: warning: couldn't open directory 'm4': No such file or directory

glibtoolize: putting auxiliary files in '.'.

glibtoolize: copying file './ltmain.sh'

glibtoolize: putting macros in AC_CONFIG_MACRO_DIRS, 'm4'.

glibtoolize: copying file 'm4/libtool.m4'

glibtoolize: copying file 'm4/ltoptions.m4'

glibtoolize: copying file 'm4/ltsugar.m4'

glibtoolize: copying file 'm4/ltversion.m4'

glibtoolize: copying file 'm4/lt~obsolete.m4'

configure.ac:18: error: possibly undefined macro: AC_MSG_FAILURE

      If this token and others are legitimate, please use m4_pattern_allow.

      See the Autoconf documentation.

autoreconf: /opt/local/bin/autoconf failed with exit status: 1


You probably want to post (a) the modifications you made to
autotools-whatever, and (b) the resulting compile and link commands.

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mta.openssl.org/pipermail/openssl-dev/attachments/20160309/bdf91ea0/attachment.html>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: smime.p7s
Type: application/pkcs7-signature
Size: 4324 bytes
Desc: not available
URL: <http://mta.openssl.org/pipermail/openssl-dev/attachments/20160309/bdf91ea0/attachment.bin>

More information about the openssl-dev mailing list