[openssl-dev] Errors when loading an OpenSSL RSA Engine

Richard Levitte levitte at openssl.org
Wed Mar 9 16:38:25 UTC 2016

In message <1457534732287-64483.post at n7.nabble.com> on Wed, 9 Mar 2016 07:45:32 -0700 (MST), danigrosu <dni.grosu at gmail.com> said:

dni.grosu>     danigrosu wrote
dni.grosu>     I'm just trying to implement an RSA engine and I thought that this
dni.grosu>     would be a good start.
dni.grosu>     I tryed successfully the MD5 Engine written by Richard Levitte and
dni.grosu>     my next step is to build an RSA engine
dni.grosu>     which I will use in my application.
dni.grosu>     I think my problem is simple and it's just something that I miss.
dni.grosu> Relating to the MD5 Engine, I tryed to build the git version manually
dni.grosu> with these commands:
dni.grosu> $ gcc -fPIC -o rfc1321/md5c.o -c rfc1321/md5c.c
dni.grosu> $ gcc -fPIC -o md5-engine.o -c e_md5.c
dni.grosu> $ gcc -shared -o md5-engine.so -lcrypto md5-engine.o rfc1321/md5c.o
dni.grosu> ... and it failed when I tried to load the engine, but using the
dni.grosu> autotools and a few modifications it worked.

Exactly how did it fail?  It's a bit hard to diagnose unless you show
us what you were told...  I assume there were some error messages?

dni.grosu> So, maybe, the same problem is here, with the RSA-X engine.
dni.grosu> Maybe Mr. Levitte could clarify this.

I'd say that my building lines worked for me ;-)
Recent experience has shown me that it might not be true for everyone.
libtool is good at figuring out what's needed on the local system,
that's probably why you get better results that way.


More information about the openssl-dev mailing list