[openssl-dev] [openssl.org #4427] PERL requirements disconnect

Richard Levitte via RT rt at openssl.org
Mon Mar 14 14:35:49 UTC 2016

Vid Mon, 14 Mar 2016 kl. 01.59.19, skrev noloader at gmail.com:
> The README.PERL states:
> You MUST have at least Perl version 5.10.0 installed. This
> minimum requirement is due to...
> However, the Configure source files use:
> require 5.000;


> $ grep -R 'require 5' *
> external/perl/Text-Template-1.46/lib/Text/Template.pm:require 5.004;

That's an external module that we've bundled because it's not part of the core
perl modules.

> And:
> $ find $PWD -name '*.pl' -exec grep 'require [0-9]' {} \;
> $
> It seems like there's a disconnect between the sources and the
> documentation. 1.1.0 seems like a perfect time to consolidate and
> align the requirements.

The other perl scripts don't necessarely have the same demands. The primary
ones that we do comment on in README.PERL are configuration stuff and testing

Closing this ticket, as it seems the goal is reached re Configure, where the
version check was lacking


Richard Levitte
levitte at openssl.org

Ticket here: http://rt.openssl.org/Ticket/Display.html?id=4427
Please log in as guest with password guest if prompted

More information about the openssl-dev mailing list