[openssl-dev] [openssl.org #4445] Configure does not honor enable-afalgeng

noloader@gmail.com via RT rt at openssl.org
Fri Mar 18 13:26:34 UTC 2016

On Fri, Mar 18, 2016 at 9:18 AM, Matt Caswell via RT <rt at openssl.org> wrote:
> On 18/03/16 12:52, noloader at gmail.com via RT wrote:
>> I've configured with:
>>     ./config enable-afalgeng
>> When I run the self tests, I see:
>>   ../test/recipes/30-test_afalg.t ........... skipped: test_afalg not
>> supported for this build
> You should not need to use enable-afalgeng at all. It is enabled by
> default unless for some reason it is not supported by your system.
> Reasons that it might not be supported:
> - You are not running Linux
> - You are not building "shared" or have otherwise disabled dynamic-engines

None of these work to enable it. I tried them incrementally, but did
not list them because I don't care about them.

    $ ./config shared enable-pic enable-dso enable-engine enable-afalgeng

This is what I am trying to test... Kernel version greater than 2.6
and less than 4.1.

> - uname reports a kernel version less than 4.1.0
> - Your linux headers are less than 4.1.0

If the library is going to reject an option, then maybe it should
produce an info, warning or error. Better, honor the configuration and
these problems go away :)

Ticket here: http://rt.openssl.org/Ticket/Display.html?id=4445
Please log in as guest with password guest if prompted

More information about the openssl-dev mailing list