levitte at openssl.org
Fri Jul 24 14:55:40 UTC 2020
We're talking APIs (*), that includes the types. So yes, that's a
(*) if people stopped using "API" when they mean "function", that
would save the world from a pile of confusion.
On Thu, 23 Jul 2020 18:45:49 +0200,
Short, Todd wrote:
> They also correspond directly to EVP_MAC and EVP_KDF types. Would the types change as well?
> -Todd Short
> // tshort at akamai.com
> // “One if by land, two if by sea, three if by the Internet."
> On Jul 23, 2020, at 11:56 AM, Matt Caswell <matt at openssl.org> wrote:
> On 23/07/2020 16:52, Richard Levitte wrote:
> On Thu, 23 Jul 2020 12:18:10 +0200,
> Dr Paul Dale wrote:
> There has been a suggestion to rename EVP_RAND to OSSL_RAND. This seems reasonable.
> Would it
> also make sense to rename the other new APIs similarly.
> More specifically, EVP_MAC and EVP_KDF to OSSL_MAC and OSSL_KDF respectively?
> This is a good question...
> Historically speaking, even though EVP_MAC and EVP_KDF are indeed new
> APIs, they have a previous history of EVP APIs, through EVP_PKEY. The
> impact of relocating them outside of the EVP "family" may be small,
> but still, history gives me pause.
> RAND doesn't carry the same sort of history, which makes it much
> easier for me to think "just do it and get it over with"...
> I have the same pause - so I'm thinking just RAND for now.
> No public key for CFC553A2BA1A0ED1 created at 2020-07-23T18:45:49+0200 using RSA
Richard Levitte levitte at openssl.org
OpenSSL Project http://www.openssl.org/~levitte/
More information about the openssl-project