Late Monthly Status Report (November 2020)

Richard Levitte levitte at openssl.org
Fri May 7 07:21:55 UTC 2021


Apart from normal business, such as normal reviews, OMC business,
normal system administration tasks, small fixes, etc., key activities
this month:

* Development:

  - [WIP] APPS: Refactoring dsaparam and dhparam
    (PR openssl/openssl#12072)
  - EVP: Adapt EVP_PKEY2PKCS8() to better handle provider-native keys
    (PR openssl/openssl#12995)
  - Deprecate RSA harder
    (PR openssl/openssl#13096)
  - Add new provider encoders implementations for more output standards, take 2
    (PR openssl/openssl#13167)
  - util/fix-deprecation: DEPRECATEDIN conversion util for public headers
    (PR openssl/openssl#13239)
  - Simplify and clarify doc/internal/man7/deprecation.pod
    (PR openssl/openssl#13240)
  - test/endecoder_legacy_test.c: new test for legacy comparison
    (PR openssl/openssl#13262)
  - test/recipes/90-test_shlibload.t: Skip when address sanitizer enabled
    (PR openssl/openssl#13281)
  - Cleanup error reporting in crypto/
    (PR openssl/openssl#13318)
  - Cleanup error reporting providers
    (PR openssl/openssl#13319)
  - Really deprecate the old NAMEerr() macros
    (PR openssl/openssl#13320)
  - Fix test/recipes/80-test_ca.t to skip_all properly in a subtest
    (PR openssl/openssl#13331)
  - EVP: Have all EVP_PKEY check functions export to provider if possible
    (PR openssl/openssl#13334)
  - Small passphrase reading fixes
    (PR openssl/openssl#13346)
  - ERR: deprecate all old ERR_load_ and stop producing new ones
    (PR openssl/openssl#13390)
  - Fix SUPPORT.md for better readability
    (PR openssl/openssl#13398)
  - DOC: Fixup the description of the -x509_strict option
    (PR openssl/openssl#13412)
  - util/mkrc.pl: Make sure FILEVERSION and PRODUCTVERSION have four numbers
    (PR openssl/openssl#13415)
  - util/find-doc-nits: check podchecker() return value
    (PR openssl/openssl#13416)
  - DOC: Fix example in OSSL_PARAM_int.pod
    (PR openssl/openssl#13426)
  - SSL: Change SSLerr() to ERR_raise()
    (PR openssl/openssl#13450)
  - TEST: Make our test data binary
    (PR openssl/openssl#13477)
  - DOC: Add note on how to terminate an OSSL_PARAM array
    (PR openssl/openssl#13478)
  - APPS: Guard use of IPv6 functions and constants with a check of AF_INET6
    (PR openssl/openssl#13484)
  -  ERR: Restore the similarity of ERR_print_error_cb() and ERR_error_string_n()
    (PR openssl/openssl#13510)
  - APPS: Modify the way apps/cmp.c silences the UI_METHOD when -batch is given
    (PR openssl/openssl#13512)
  - EVP_PKEY & DSA: Make DSA EVP_PKEY_CTX parameter ctrls / setters more available
    (PR openssl/openssl#13530)
  - TEST: Fix path length in test/ossl_store_test.c
    (PR openssl/openssl#13546)
  - RSA: correct digestinfo_ripemd160_der[]
    (PR openssl/openssl#13562)
* Web:
  - REVIEWED: Update newsflash for alpha 8 release
    (PR openssl/web#206 by mattcaswell)
  - REVIEWED: Update newsflash for new release
    (PR openssl/web#208 by mattcaswell)

-- 
Richard Levitte         levitte at openssl.org
OpenSSL Project         http://www.openssl.org/~levitte/


More information about the openssl-project mailing list