[openssl-users] fipsld linker out of control forking, last step of build

Mark mseaborn62 at hotmail.com
Fri Jun 5 13:49:48 UTC 2015

MAY BE REPOSTING TRYING TO MOVE FROM NABBLE TO OFFICIAL OPENSSL POSTINGI was wondering if someone has seen this issue before. I am guessing the problem is on my side because  can replicate it on Debian 8 and Ubuntu 14.4. I am using OpenSSL 1.0.2c and the crypto module from OpenSSL ecp 2.0.9 env settings CC=/home/myssluser/workspace/libs/openssl-fips-ecp-2.0.9/fips/fipsld FIPSLD_CC=/usr/bin/gcc FIPSDIR=/usr/local/ssl/fips-2.0 for building fips canister ./config fipscanisterbuild no-asm make make install using ./config fips no-asm make make install This seemed to be pretty straight forward. I think i created the fipscanister.o correctly. Everything compiled and linked for the canister. I liked it to a small test app that worked. I then tried to build openssl, it fine but on the last linking step the linker just keep forking processes out of control on both OSs until i got a message that the linker cannot fork any new processes. Any pointers would be appreciated. /home/myssluser/workspace/libs/openssl-fips-ecp-2.0.9/fips/fipsld: 174: /home/myssluser/workspace/libs/openssl-fips-ecp-2.0.9/fips/fipsld: Cannot fork ../Makefile.shared:164: recipe for target 'link_app.' failed make[2]: *** [link_app.] Error 2 make[2]: Leaving directory '/home/myssluser/workspace/libs/openssl-1.0.2a/apps' Makefile:153: recipe for target 'openssl' failed make[1]: *** [openssl] Error 2 make[1]: Leaving directory '/home/myssluser/workspace/libs/openssl-1.0.2a/apps' Makefile:285: recipe for target 'build_apps' failed make: *** [build_apps] Error 1 myssluser at debian8:~/workspace/libs/openssl-1.0.2a$  		 	   		  
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mta.openssl.org/pipermail/openssl-users/attachments/20150605/067548d4/attachment.html>

More information about the openssl-users mailing list