[openssl-users] Windows Compile Fails

Jay Foster jayf0ster at roadrunner.com
Fri Jun 19 19:51:11 UTC 2015

On 6/19/2015 10:52 AM, Jay Foster wrote:
> On 6/19/2015 8:55 AM, Michael Wojcik wrote:
>>> From: openssl-users [mailto:openssl-users-bounces at openssl.org] On 
>>> Behalf
>>> Of Jay Foster
>>> Sent: Friday, June 19, 2015 11:49
>>> I started over from a clean directory and the build completed.  On
>>> linux, I would end up with two libraries (libssl, libcrypto). I don't
>>> see these on Windows in the out32dll directory.  Does Windows create
>>> different library names?  I'm looking for the equivalent static
>>> libraries for libssl and libcrypto to link with my application.
>> The Windows static libraries are named libeay32.lib and ssleay32.lib, 
>> for historical reasons. At any rate, that's what I have in my Windows 
>> build directory; I believe those are the standard names.
> Thanks, I see those.
> _______________________________________________
> openssl-users mailing list
> To unsubscribe: https://mta.openssl.org/mailman/listinfo/openssl-users
I got my application to compile and link.  It seemed to run OK, but when 
I tried to run it on a different Windows machine, it failed with a pop 
up dialog complaining it could not find LIBEAY32.dll.  I 'thought' I was 
statically linking this library, but apparently not.  I have no idea how 
it worked on the one machine.  What is the magic incantation to get 
Visual Studio to statically link the OpenSSL libraries?


More information about the openssl-users mailing list