[openssl-users] Windows Compile Fails

Jeremy Farrell jeremy.farrell at oracle.com
Sat Jun 20 00:32:13 UTC 2015

From: Jay Foster Sent: Friday, June 19, 2015 15:51
> I got my application to compile  and link.  It seemed to run OK, but
 > when I tried to run it on a different Windows machine, it failed
 > with a pop up dialog complaining it could not find LIBEAY32.dll.  I
 > 'thought' I was statically linking this library, but apparently not.
 >  I have no idea how it worked on the one machine.  What is the magic
 > incantation to get Visual Studio to statically link the OpenSSL
 > libraries?

You'd save us a lot of guesswork, and probably get where you want to be 
more quickly, if you would
1) tell us what version of OpenSSL you're trying to build
2) tell us what build environment you're using (presumably some command 
prompt started from VS)
3) tell us the exact sequence of commands you're executing to build it, 
starting from the tarball

Have you read INSTALL.W32? It's probably well out of date in detail, but 
still valuable to point you in the right direction. As long as you're 
using the nt.mak makefile, you should get static libraries.


J. J. Farrell

More information about the openssl-users mailing list