[openssl-users] Compiling FIPS compliant Openssl for SSE architecture

Shobha Dashottar Shobha_Dashottar at symantec.com
Sun Jun 28 04:02:33 UTC 2015

Hi All,

    I am trying to build fips compliant openssl 1.0.1m for SSE (nonSSE2) architecture .  The last time I did this, it was not fips compliant( just built openssl for SSE ) so it worked.

>From the Developer Command Prompt for VS 2012:

1.      Build fips-ecp 2.0.8
                         executing 'ms\do_fips' after setting the PROCESSOR_ARCHITECTURE=x86
               to build for SSE added the  /arch:SSE flag to the CFLAG in the Configure file  '$cflags = "$cflags$exp_cflags /arch:SSE"'
      [ Even tried to run do_fips and then recompile after setting the arch flag in the Configure script]

2.      Build openssl

     C:\openssl-1.0.1m>perl Configure VC-WIN32 no-rc5 no-idea no-ec2m [ --with-fipslibdir=<fips_lib_path> ] --prefix=c:\somedir\openssl\dir -D_USING_V110_SDK71_

     C:\openssl-1.0.1m>ms\do_nasm.bat  ( added the /arch:SSE flag to CFLAG in the ntdll.mak )

     C:\nmake -f ntdll.mak


The resulting opensssl libraries do not run on the SSE architecture machines and throw "Not a valid Win32 application"

Does anyone have any idea what is missing? I have compiled openssl with same set of commands and versions for SSE2 and those libraries work fine.

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mta.openssl.org/pipermail/openssl-users/attachments/20150627/71032476/attachment-0001.html>

More information about the openssl-users mailing list