[openssl-users] openssl-tpm-engine

Roger No-Spam roger_no_spam at hotmail.com
Tue Mar 3 13:22:47 UTC 2015


 experimenting a bit with the tpm engine (openssl_tpm_engine-0.4.2). My 
objective is to see how easy it is use this engine with openssl-1.0.1. 
Since the README file states that openssl-0.9.8 is a requirement I 
started using that openssl version. However, I have tried to use the tpm
 engine with three different openssl-0.9.8 versions, but all three 
crashes with different call stacks, when using the basic example from 
the README file (Create a self-signed cert using the TPM engine). I'm 
starting to suspect that I have overseen something fundamental. Is the 
openssl-tpm-engine supposed to work on 64 bit machines? Or is there 
something else I need to consider?

Below is some additional info on the crashes I'm seeing. All crashes are for step 2, 
openssl req -keyform engine -engine tpm -key <keyfilename> -new -x509 -days 365 -out <certfilename>

0  in BN_num_bits of bn_lib.c:232
1  in bn_i2c of x_bignum.c:117
2  in asn1_ex_i2c of tasn_enc.c:582
3  in asn1_i2d_ex_primitive of tasn_enc.c:523
4  in ASN1_item_ex_i2d of tasn_enc.c:154
5  in asn1_template_ex_i2d of tasn_enc.c:413
6  in ASN1_item_ex_i2d of tasn_enc.c:231
7  in asn1_item_flags_i2d of tasn_enc.c:122
8  in ASN1_item_i2d of tasn_enc.c:91
9  in i2d_RSAPublicKey of rsa_asn1.c:111
10 in i2d_PublicKey of i2d_pu.c:80
11 in X509_PUBKEY_set of x_pubkey.c:223
12 in X509_REQ_set_pubkey of x509rset.c:81
13 in make_REQ of req.c:1257
14 in req_main of req.c:914
15 in do_cmd of openssl.c:400
16 in main of openssl.c:318

0  in raise of /lib/x86_64-linux-gnu/libc.so.6
1  in abort of /lib/x86_64-linux-gnu/libc.so.6
2  in ?? of /lib/x86_64-linux-gnu/libc.so.6
3  in ?? of /lib/x86_64-linux-gnu/libc.so.6
4  in CRYPTO_free of mem.c:406
5  in asn1_item_combine_free of tasn_fre.c:176
6  in ASN1_item_free of tasn_fre.c:71
7  in X509_ATTRIBUTE_free of x_attrib.c:96
8  in sk_pop_free of stack.c:290
9  in EVP_PKEY_free of p_lib.c:468
10 in req_main of req.c:1183
11 in do_cmd of openssl.c:400
12 in main of openssl.c:318

I also tried openssl-0.9.8, but I didn't save the call stack of that crash.

I'm using ubuntu 14.04.

Regards Roger

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mta.openssl.org/pipermail/openssl-users/attachments/20150303/f1fa0ecf/attachment-0001.html>

More information about the openssl-users mailing list