[openssl-users] MSVC Compiling OpenSSL on Windows 64 issues with missing libs

Raymi Coevan raymi.coevan at gmail.com
Sat Jul 8 09:19:57 UTC 2017

Dear OpenSSL experts,

I'm a junior developer so please forgive me if this is a stupid question.

I'm trying to port an existing application, currently running on MacOSX and
Linux, to Windows 64 bits platform which is not my favorite environment.

I have dependencies on Poco and OpenSSL (1.1.0e is currently used on MacOSX
and Linux), and when trying to compile using MSVC2015, I get and link error
telling that libeaymt64.lib and ssleaymt64.lib are missing. I tried to find
where these dependencies are defined (pragma or linkage definitions) but
did not find. These libraries do not look to exist since I cannot find them
on MacOSX and Linux either.

I have installed OpenSSL environment and tried using precompiled libs and
headers from http://slproweb.com/download/Win64OpenSSL-1_1_0f.exe

Googling on these libs, I find they might be included in OpenSSL 1.0.2g,
however I'm not able able to find them in application's required OpenSSL
release (1.1.x).

I'm sure I'm missing some points but cannot figure out what after hours of

Can someone please help me?

Thanks in advance


-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mta.openssl.org/pipermail/openssl-users/attachments/20170708/71739c4b/attachment-0001.html>

More information about the openssl-users mailing list