[openssl-users] nmake win32 failure

Matt Caswell matt at openssl.org
Fri Jul 14 17:14:20 UTC 2017

On 14/07/17 16:41, Andrea Smith wrote:
> I have successfully gotten a setup for win64 and am trying to get one
> for win32 now. I am using version 1.1.0f. I ran the following configure
> command successfully:
> perl Configure VC-WIN32 -no-asm
> However, when I run the nmake command, I get linker errors (unresolved
> external symbol) for OPENSSL_UplinkTable while it's creating
> libcrypto.lib.

This happens if you attempt to build OpenSSL configured for 32-bit from
the Visual Studio Developer command prompt for x64. You need to use the
developer command prompt for 32 bit.

Incidentally, I would recommend against no-asm unless you really need to
use it. Using it will impact both your performance (no optimised
algorithm implementations) and your security (misses out some constant
time implementations).

> All of the examples I am seeing online refer to the
> "ms/do_ms.bat" command, which seems to have gone away recently.

Those examples are referring to OpenSSL 1.0.2 and below. The build
procedure changed significantly in OpenSSL 1.1.0.


More information about the openssl-users mailing list