[openssl-users] OCSP_BASICRESP_verify() in 1.1.0
wouter.verhelst at fedict.be
Tue Oct 31 16:42:48 UTC 2017
On 31-10-17 17:26, Matt Caswell wrote:
> I agree its not a great name for it. Unfortunately we are stuck with it
> for compatibility reasons. If we renamed it we would break any code that
> is currently using it. We could introduce a new flag with a different
> name which does the same thing - but I'm not sure that does anything to
> make things less confusing.
You could always keep the old name around and mark it deprecated. GCC
even has a pragma for that -- __attribute__((deprecated)) -- although I
doubt it works on macros (haven't tested that).
I suppose it might be too much of an effort for too little gain, though.
More information about the openssl-users