[openssl-users] Building OpenSSL 1.1.0h on HPUX 11 PARISC2 64bit

Clint Redwood clint at screwtape.co.uk
Thu Jun 7 11:50:37 UTC 2018


Since I can’t find any current pre-build versions of OpenSSL for this platform, I am trying to build OpenSSL 1.1.0h with GCC 4.6.1 on HPUX 11.0.

I’ve tried a basic ./config approach but that appears to select hpux-parisc1_1-gcc when I want PARISC2. 

I tried building it, but had problems
a) with several .s assembly files not compiling with the gnu assembler (but they do compile with the native hpux assembler)
b) when trying to link getting a "missing /opt/langtools/lib/libcomp.sl" which I understand from a few forum entries is redundant in HPUX 11 (I can't see why it's being requested anyway)

So I checked wondered if the problem is that it is configuring for the wrong platform, so I have reviewed the code in "config", and in line 778 the OUT variable is set to "hpux-parisc1_1-$(CC)" with a comment saying that PARISC2 is no longer supported in a 32 bit build. However, I'm trying to build it in 64 bit.

I've tried commenting this line out, and configuring for hpux-parisc2-gcc, and I still get the assembly failures, but I now also get compile failures in 
  314:5 error: unknown type name 'Dl_info'
  328:30 error:request for member 'dli_fname' in something not a structure or union
  333:25 error:request for member 'dli_fname' in something not a structure or union

I've not been able to get past this point, so I don't know if the linking would be a problem.

Given I'm trying to build for 64 bit, should this be built for parisc_1_1 or parisc2, and how might I go about fixing these issues?



Clint Redwood 

Screwtape Limited, Registered 06663232, Babington House, 26 College Road, Chilwell, Nottingham NG9 4AS

More information about the openssl-users mailing list