[openssl-users] Building OpenSSL 1.1.0h on HPUX 11 PARISC2 64bit

Andy Polyakov appro at openssl.org
Fri Jun 8 10:19:54 UTC 2018


> Since I can’t find any current pre-build versions of OpenSSL for this platform, I am trying to build OpenSSL 1.1.0h with GCC 4.6.1 on HPUX 11.0.
> I’ve tried a basic ./config approach but that appears to select hpux-parisc1_1-gcc when I want PARISC2. 
> I tried building it, but had problems
> a) with several .s assembly files not compiling with the gnu assembler (but they do compile with the native hpux assembler)
> b) when trying to link getting a "missing /opt/langtools/lib/libcomp.sl" which I understand from a few forum entries is redundant in HPUX 11 (I can't see why it's being requested anyway)
> So I checked wondered if the problem is that it is configuring for the wrong platform, so I have reviewed the code in "config", and in line 778 the OUT variable is set to "hpux-parisc1_1-$(CC)" with a comment saying that PARISC2 is no longer supported in a 32 bit build. However, I'm trying to build it in 64 bit.

You should keep in mind that it takes gcc that actually generates 64-bit
code. While it seems to be self-obvious, it was source of confusion
earlier. For example you can observe hppa2.0w-hp-hpux11.11 in gcc -v
output, yet it would generate 32-bit code [even though "w" customarily
is reference to 64 bits]. But let's say that your gcc generates 64-bit
code. Trouble is that ./config in 1.1.0 fails to detect bitness
correctly. It was corrected in master/1.1.1, but in 1.1.0 you are stuck
with manual selection as argument to ./Configure. The choice is between
hpux64-parisc2-cc and hpux64-parisc2-gcc. As for gnu assembler, it's
known limitation. I mean yes, OpenSSL PA-RISC assembly can be compiled
only with vendor assembler. So that if your gcc can't be told to use
native HP-UX assembler, then you have to configure with no-asm or
configure for hpux64-parirsc2-cc, i.e. vendor compiler.

More information about the openssl-users mailing list