[openssl-users] Unable to select NULL or NULL-MD5

Eric Jacksch eric at jacksch.com
Wed Mar 28 23:14:58 UTC 2018


I'm using OpenSSL for testing and recently compiled 1.1.0g and h. I'm
seeing the same behaviour in both.

openssl ciphers -v list the NULL ciphers, but when I try to use NULL or
NULL-MD5 I get the same result:  No ciphers available.

I've tried several compile options to no avail.

Can anyone point me in the right direction?


./openssl s_client -connect x.x.x.x:443 -cipher NULL


140735917126464:error:141640B5:SSL routines:tls_construct_client_hello:no
ciphers available:ssl/statem/statem_clnt.c:800:


no peer certificate available


No client certificate CA names sent


SSL handshake has read 0 bytes and written 0 bytes

Verification: OK


New, (NONE), Cipher is (NONE)

Secure Renegotiation IS NOT supported

Compression: NONE

Expansion: NONE

No ALPN negotiated


    Protocol  : TLSv1.2

    Cipher    : 0000




    PSK identity: None

    PSK identity hint: None

    SRP username: None

    Start Time: 1522278574

    Timeout   : 7200 (sec)

    Verify return code: 0 (ok)

    Extended master secret: no

Eric Jacksch, CPP, CISM, CISSP
+1 613 482-7650
eric at jacksch.com
Twitter: @EricJacksch
https://SecurityShelf.com <https://securityshelf.com/>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mta.openssl.org/pipermail/openssl-users/attachments/20180328/19e3adc2/attachment-0001.html>

More information about the openssl-users mailing list