[openssl-users] Trouble installing openssl 1.1.0 on Ubuntu 14.04

Richard Levitte levitte at openssl.org
Wed Nov 7 06:57:36 UTC 2018

In message <1541454675952-0.post at n7.nabble.com> on Mon, 5 Nov 2018 14:51:15 -0700 (MST), EcolaneAdam <adam.lang at ecolane.com> said:

> Hello,
> Several months ago I had configured ansible to deploy openssl upgrades to
> our Ubuntu 14.04 servers and did so with the following version via apt
> module:
>         - libssl-dev=1.1.0h-2.0+ubuntu14.04.1+deb.sury.org+1
>         - openssl=1.1.0h-2.0+ubuntu14.04.1+deb.sury.org+1
> Now when doing deployments I am getting that the version is not found.  I am
> having trouble finding the correct version to reference.  Anything I have
> tried hasn't worked. 
> Any ideas?

Those package names told me I could have a look at
http://deb.sury.org, and sure enough, there was something there, with
a PPA link: https://launchpad.net/~ondrej/+archive/ubuntu/php/

You can see the full (I assume) list of available packages there, and
for OpenSSL, I find these:


So it looks to me like you're being forced to upgrade.  Note that
1.1.1 is forward compatible with 1.1.0h, so that upgrade should go


Richard Levitte         levitte at openssl.org
OpenSSL Project         http://www.openssl.org/~levitte/

More information about the openssl-users mailing list