Where to copy custom openssl engine library in openssl 1.1.0

Richard Levitte levitte at openssl.org
Tue Apr 30 08:04:41 UTC 2019

You can ask the openssl app where it goes looking for engines by
default.  Here's what it looks like with the installed openssl on my

    : ; openssl version -e
    ENGINESDIR: "/usr/lib/x86_64-linux-gnu/engines-1.1"

Note that engines aren't agnostic to the OpenSSL version...


On Thu, 25 Apr 2019 10:06:53 +0200,
Swamy J-S wrote:
> Am working in Ubuntu 18.04 with openssl 1.1.0g version. I built a custom openssl engine and now i
> want to use this engine instead of default openssl engine.
> My engine library name is libstoreengine.so and i copied this to /usr/lib/x86_64-linux-gnu/
> openssl-1.0.0/engines/ path.
> When i run my application the it says Store Engine not found. There is path issue here, am i
> copying the library in right path? I copied my library in /lib/x86_64-linux-gnu still am getting
> same error.
> Please let me know the right path where i have to copy this engine?
> Thanks and Regards,
Richard Levitte         levitte at openssl.org
OpenSSL Project         http://www.openssl.org/~levitte/

More information about the openssl-users mailing list