Using (not building) openssl with mingw on Windows 10

Ken Goldman kgoldman at
Wed Mar 20 14:46:02 UTC 2019

On 10/29/2018 7:18 AM, Jakob Bohm via openssl-users wrote:
> On 26/10/2018 23:08, Ken Goldman wrote:
>> I've been happily using the Shining Light 32-bit binaries with both 
>> openssl 1.0 and 1.1 and mingw.
>> On a new machine, I tried the 64-bit binaries.  However, they're 
>> missing the openssl/lib/mingw directory where the .a files resided.
>> It looks like the link procedure changed.  Any hints before I start 
>> experimenting?
> Note that Win32 (Microsoft) .LIB files are actually standard unix-style
> .a files with the file names changed to match the the historic
> MS-DOS/Win16 practice (which had a different file format).
> So it is highly likely the .LIB files can be used with mingw by just
> copying/symlinking them, or even just using a Mingw option to load
> .LIB files.
> Beware however of the crazy GNU interpretation that listing a library
> file explicitly means include *all* the code from the library, not
> just the referenced object files.

Getting back to this:

I tried mingw linking against these

"c:/program files/openssl64/lib/libcrypto.lib"
"c:/program files/openssl64/lib/libssl.lib"

but the gcc linker failed to find the openssl functions.

Anyone have any ideas?


I observe that the .a file is 3 mb while the .lib is 900k.


The 32-bit build still has the mingw .a files, which I suppose
is a work around.

More information about the openssl-users mailing list