'in_addr_t' in openssl 1.1.1g ??

prudvi raj rajprudvi98 at gmail.com
Wed Aug 5 20:21:35 UTC 2020

Hi there,

I got this error during compilation , in file b_addr.c :
In function 'BIO_lookup_ex':
/b_addr.c:748:9: error: unknown type name 'in_addr_t'

I see that "in_addr_t" is defined in "netinet/in.h" & "arpa/inet.h" in
toolchain (typedef uint32_t in_addr_t;).
i have even tried to #include<> these files directly but that doesn't seem
to fix the error. Btw, these files are included already , but under
conditional #if 's.

I am surprised why the error persists , even after directly including the
respective source file ??

Here's the config options i used :
./Configure  no-threads no-dso no-ct no-shared no-zlib no-asm no-engine
no-bf no-aria no-blake2 no-camellia no-cast no-md2 no-md4 no-mdc2 no-ocsp
no-rc2 no-rc5 no-hw-padlock no-idea no-srp gcc  --with-rand-seed=none

PS : same error without any cross compile prefix , using only gcc.

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://mta.openssl.org/pipermail/openssl-users/attachments/20200806/dccdd09f/attachment.html>

More information about the openssl-users mailing list