[EXTERNAL] Re: Adding new directory to Configure

Martin Bonner Martin.Bonner at entrust.com
Wed Aug 2 12:33:58 UTC 2023

Martin Bonner

On 28/07/2023 12:16 Matt Caswell wrote:

> On 28/07/2023 12:09, Martin Bonner via openssl-users wrote:
>> For various reasons, we build a set of utilities along with OpenSSL.
>> In OpenSSL 1.1.1 we just changed:
>> ...
>> (line 321 of Configure)|
>> and everything worked.  There is no such line in Configure for 3.0,

> Modify the build.info file in the top level directory to change the value for SUBDIRS.

That was _amazingly_ quick (unlike my response - thank you anyway).
Also, sorry about the HTML formatting on the first post.

> You will need a new build.info file in your sub-directory. There are plenty of examples of these in the source tree.

We've already had a build.info in the sub-directory, and it all just worked.

I have to say that the configuration mechanism has improved since 1.1.1.
With 3.0, ./Configure worked flawlessly.  With 1.1.1 ./Configure said
"try ./configure", so I tried that and it failed too.

(I didn't spend any time trying to diagnose the problem, because I now
have a working 3.0 build.  I don't suppose anyone else is interested in
debugging it either, given 1.1.1 is about to go out of support.)

Martin Bonner
Any email and files/attachments transmitted with it are intended solely for the use of the individual or entity to whom they are addressed. If this message has been sent to you in error, you must not copy, distribute or disclose of the information it contains. Please notify Entrust immediately and delete the message from your system.

More information about the openssl-users mailing list