Error-wrong version number

kgoudra at kgoudra at
Thu Sep 7 14:35:04 UTC 2023


We are seeing below error during TLS/SSL handshake(SSL_accept()) between client and server (both are windows).

"64160000:error:0A00010B:SSL routines:ssl3_get_record:wrong version number:ssl\\record\\ssl3_record.c:355:\n"
ERR_get_error() has returned 167772427

Everything before SSL_accept looks Ok.

Client is windows running Openssl 1.1.1K and Server is windows running Openssl 3.0.8, same config is working fine when client is linux.

Solutions tried:
Tried to lower SSL security by --- SSL_CTX_set_security_level(m_pCtx_IPC, 0); , but it didn't help.

Observed "Remote host suddenly stooped" error in client logs and it is because server sent "Flags: 0x014 (RST, ACK)" to client which might be because it received some non TLS data.

Please let me know if anyone could help us to resolve above issue.

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the openssl-users mailing list