Cleaning up include file inconsistencies

Dr. Matthias St. Pierre Matthias.St.Pierre at
Sat Jul 6 17:03:27 UTC 2019

> For things that are private to that sub-system (sorry, "package" doesn't sound right)

Neither does it to me, apologies. I was looking for the right word, but nothing except
"package" came to my mind. And I was too lazy to search for it in the docs.

> Me, I'm wondering if it wouldn't be clearer if we renamed
> crypto/include/internal -> crypto/include/crypto, and thereby did
> this:
>     #include "crypto/evp.h"
> That, to me, is much clearer than the "_int" suffix.

This sounds like an excellent idea to me.


More information about the openssl-project mailing list