Cleaning up include file inconsistencies

Richard Levitte levitte at
Sat Jul 6 17:22:37 UTC 2019

On Sat, 06 Jul 2019 19:03:27 +0200,
Dr. Matthias St. Pierre wrote:
> > For things that are private to that sub-system (sorry, "package" doesn't sound right)
> Neither does it to me, apologies. I was looking for the right word, but nothing except
> "package" came to my mind. And I was too lazy to search for it in the docs.

It's not in the docs.  The original term is "library", and that's
because SSLeay and early OpenSSL were designed to make it possible to
build a separate library from any of those subdirectories.
Traces of this is still seen in the error codes.

"sub-system" is a term that some of us have started using, mostly on
github.  I find it catchy enough that I've started using it

> > Me, I'm wondering if it wouldn't be clearer if we renamed
> > crypto/include/internal -> crypto/include/crypto, and thereby did
> > this:
> > 
> >     #include "crypto/evp.h"
> > 
> > That, to me, is much clearer than the "_int" suffix.
> This sounds like an excellent idea to me.

"Someone" should create a PR...


Richard Levitte         levitte at
OpenSSL Project

More information about the openssl-project mailing list