API renaming

Dr Paul Dale paul.dale at oracle.com
Thu Jul 23 10:18:10 UTC 2020

There has been a suggestion to rename EVP_RAND to OSSL_RAND.  This seems reasonable.  Would it also make sense to rename the other new APIs similarly.
More specifically, EVP_MAC and EVP_KDF to OSSL_MAC and OSSL_KDF respectively?

Dr Paul Dale | Distinguished Architect | Cryptographic Foundations 
Phone +61 7 3031 7217
Oracle Australia

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://mta.openssl.org/pipermail/openssl-project/attachments/20200723/28a1d936/attachment-0001.html>

More information about the openssl-project mailing list