API renaming

Matt Caswell matt at openssl.org
Thu Jul 23 15:56:26 UTC 2020

On 23/07/2020 16:52, Richard Levitte wrote:
> On Thu, 23 Jul 2020 12:18:10 +0200,
> Dr Paul Dale wrote:
>> There has been a suggestion to rename EVP_RAND to OSSL_RAND.  This seems reasonable.  Would it
>> also make sense to rename the other new APIs similarly.
>> More specifically, EVP_MAC and EVP_KDF to OSSL_MAC and OSSL_KDF respectively?
> This is a good question...
> Historically speaking, even though EVP_MAC and EVP_KDF are indeed new
> APIs, they have a previous history of EVP APIs, through EVP_PKEY.  The
> impact of relocating them outside of the EVP "family" may be small,
> but still, history gives me pause.
> RAND doesn't carry the same sort of history, which makes it much
> easier for me to think "just do it and get it over with"...

I have the same pause - so  I'm thinking just RAND for now.


More information about the openssl-project mailing list