Status of the remaining beta1 PRs

Matt Caswell matt at
Fri Sep 18 16:09:12 UTC 2020

On 18/09/2020 16:59, Tomas Mraz wrote:
> On Fri, 2020-09-18 at 16:24 +0100, Matt Caswell wrote:
>> 1 PR which is in a state of "its unclear what we do with this":
>> [WIP] Rename some XXX_ex() related methods to XXX_with_libctx()
>> With no agreement on a naming convention its unclear if this should
>> go
>> ahead or not
> We should do something consistent - either rename the _ex functions
> that just add libctx (and property query) or rename the existing
> with_libctx functions to _ex functions.
> The current state is a mess having some functions with _ex and some
> with _with_libctx.

The current vote on the policy is still ongoing (the subject of this PR
is the one covered by chapter 6.2 in the proposed coding style).
Unfortunately there is currently no clear outcome on that vote and there
are still a significant number of outstanding votes.

Without a clear decision one way or another on that vote we cannot
decide a way forward. If the vote passes, then it is clear what we have
to do. If the vote fails then we will probably have to make a one off
vote about what to do about existing _with_libctx vs _ex discrepancies
without making a policy out of it.

Please can I encourage OTC members to vote one way or the other so that
we can move forward.


More information about the openssl-project mailing list