Status of the remaining beta1 PRs

Tomas Mraz tmraz at
Fri Sep 18 15:59:10 UTC 2020

On Fri, 2020-09-18 at 16:24 +0100, Matt Caswell wrote:
> 1 PR which is in a state of "its unclear what we do with this":
> [WIP] Rename some XXX_ex() related methods to XXX_with_libctx()
> With no agreement on a naming convention its unclear if this should
> go
> ahead or not

We should do something consistent - either rename the _ex functions
that just add libctx (and property query) or rename the existing
with_libctx functions to _ex functions.

The current state is a mess having some functions with _ex and some
with _with_libctx.

Tomáš Mráz
No matter how far down the wrong road you've gone, turn back.
                                              Turkish proverb
[You'll know whether the road is wrong if you carefully listen to your

More information about the openssl-project mailing list