[openssl-users] lib4758cca.bad

neil carter neil.carter at oracle.com
Thu Sep 24 17:50:43 UTC 2015


I just completed compiling the openssl-1.0.2d bundle on 64-bit linux 
(OEL 5.8).  I say completed, but I cheated somewhat.


         ./config --prefix=/usr/local shared no-dso
         make install

When I ran the 'make install' the first time, it failed at the 4758cca 
section with several errors  about all of the lib* files in the engines 
sub-directory.  I no longer have the exact error message, but it 
basically stated that the lib4758cca.bad file, and ten other lib*.bad 
files, did not exist.  OK, interesting.  I cd'd to the engines 
sub-directory and looked, there were no lib*.bad files.  On a lark, I 
touched all eleven of the missing lib*.bad filenames (one for each of 
the lib*.so files), cd'd back out of the engines sub-directory, and ran 
'make install' again.  This time it went further but then informed me 
that the engines/ccgost/libgost.bad file did not exist.  I touched this 
filename, cd'd back out of the engines/ccgost sub-directory, ran 'make 
install' again and everything worked seemingly fine.  I now have a 
working copy of openssl-1.0.2d on this system.  At least I think I do.

I'm relatively certain this is not a sanctioned work-around for this 
error.  Can someone please explain what these lib*.bad files are 
supposed to be or what they signify?



-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mta.openssl.org/pipermail/openssl-users/attachments/20150924/b2824df0/attachment-0001.html>

More information about the openssl-users mailing list