[openssl-users] Warning OPENSSL_1.0.0 not found (custom build OpenSSL library)

Sandra Schreiner sasc0041 at stud.hs-kl.de
Sun Feb 21 16:15:45 UTC 2016


I am currently developing a C++ application with Boost Asio SSL Sockets. Boost Asio uses OpenSSL for it's TLS support. My application will be ported to Android in the future so I tried to build OpenSSL by myself for my current architecture (Linux, Debian, 64bit, VM) in the first run and link it to my application. Everything went well until I ran the application. At first I received a warning 'no version information found' for OpenSSL. 
I fixed this by providing a version info file like descripted here: http://stackoverflow.com/questions/18390833/no-version-information-available. I changed the version to 1.0.1, because I use OpenSSL 1.0.1f:

OPENSSL_1.0.1 {

Now I receive a warning 'version `OPENSSL_1.0.0' not found'. I also saw this thread http://openssl.6102.n7.nabble.com/version-script-td63374.html which mentions there is a version script patch for debian and ubuntu in order to get rid of this warnings. 
Unfortunately now I'm confused, because I'm not very familar with building own librarys and linux distributions in general. I don't know how to apply a version patch to a library which I build in a custom directory and which will be shipped together with my application.  Would it be necessary to apply this patch to every device where my app is running? Is this even possible for android? 
At the moment I'm using a CMake file to build OpenSSL:

  SOURCE_DIR ${openssl_src}
  CONFIGURE_COMMAND ${openssl_src}/config no-ssl2 no-ssl3 shared --openssldir=${openssl_prefix} -Wl,--version-script=${openssl_src}/openssl.ld
  PREFIX ${openssl_prefix}
  INSTALL_COMMAND make install

Is it possible to integrate the patch for 1.0.1f in my build process? Or is there a other solution to get rid of this warnings?

Many thanks in advance,

More information about the openssl-users mailing list