[openssl-users] Warning OPENSSL_1.0.0 not found (custom build OpenSSL library)

Kurt Roeckx kurt at roeckx.be
Sun Feb 21 18:26:00 UTC 2016

On Sun, Feb 21, 2016 at 04:15:45PM +0000, Sandra Schreiner wrote:
> Hello,
> I am currently developing a C++ application with Boost Asio SSL Sockets. Boost Asio uses OpenSSL for it's TLS support. My application will be ported to Android in the future so I tried to build OpenSSL by myself for my current architecture (Linux, Debian, 64bit, VM) in the first run and link it to my application. Everything went well until I ran the application. At first I received a warning 'no version information found' for OpenSSL. 
> I fixed this by providing a version info file like descripted here: http://stackoverflow.com/questions/18390833/no-version-information-available. I changed the version to 1.0.1, because I use OpenSSL 1.0.1f:
> OPENSSL_1.0.1 {
>     global:
>     *;
> };

I suggest you use the version script from the package you're
trying to replace.


More information about the openssl-users mailing list