[openssl-users] Helps needed regarding the error "fingerprint does not match:fips.c:232:"

cloud force cloud.force858 at gmail.com
Thu Feb 25 01:59:25 UTC 2016

I built the FIPS capable OpenSSL in the standard way (i.e. ./config fips; make;
make install) and it worked.

After some tracing on the source code of fips.c I found that the mismatch
error was due to the fact that the content of the two variables "sig" and
"FIPS_SIGNATURE" are different when the OpenSSL lib was built using the
Ubuntu build script. When building the lib using the standard way, the
content of "sig" and "FIPS_SIGNATURE" are the same.

Does anyone know what could cause the content of "sig" and "FIPS_SIGNATURE"
 to be different (and hence causes the "fingerprint does not match" error)?

Thanks and any suggestions are truly appreciated.

On Tue, Feb 23, 2016 at 5:01 PM, Dr. Stephen Henson <steve at openssl.org>

> On Tue, Feb 23, 2016, cloud force wrote:
> > Hi All:
> >
> > I built the FIPS modules on Ubuntu platform and was trying to build the
> > FIPS capable OpenSSL library.
> >
> > The build went fine but when I ran the following test, the fingerprint
> > error showed up:
> >
> > *OPENSSL_FIPS=1 openssl md5*
> >
> I suggest you first try building the FIPS capable OpenSSL in the standard
> way
> i.e.
> ./config fips
> make
> and see if you get the same problem.
> Steve.
> --
> Dr Stephen N. Henson. OpenSSL project core developer.
> Commercial tech support now available see: http://www.openssl.org
> --
> openssl-users mailing list
> To unsubscribe: https://mta.openssl.org/mailman/listinfo/openssl-users

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mta.openssl.org/pipermail/openssl-users/attachments/20160224/4cf1fe9f/attachment.html>

More information about the openssl-users mailing list