[openssl-users] Failed to install OpenSSL 1.1.0 using 'nmake install'

Jing Liu jingmliu at sina.com
Wed Sep 21 12:35:27 UTC 2016

I've tried all my best to solve this problem but failed. Can you help me?


- OS: Windows 10

- Perl: ActivePerl 5.12.2 build 1202

- Development environment: MS Visual Studio 2010 SP1

- OpenSSL version: OpenSSL 1.1.0


I tried to compile and install OpenSSL 1.1.0 according to the following


1. decompressed OpenSSL 1.1.0 software package to directory

2. opened the "Visual Studio 2010 command prompt" window using an
Administrator identity;

3. switched to the directory "D:\openssl-1.1.0";

4. D:\openssl-1.1.0> perl Configure VC-WIN32;

5. D:\openssl-1.1.0> nmake;

6. D:\openssl-1.1.0> nmake test;


> So far, all steps went smoothly, but ...  


7. D:\openssl-1.1.0> nmake install;


Here, I got the following error and there was no file being copied to the
destination directories even though those directories were successfully


    Microsoft (R) program maintenance utility 10.00.30319.01 copy right (C)
Microsoft Corporation.All rights reserved.  

*** Installing development files  

created directory 'C:/Program Files (x86)/OpenSSL'  

created directory 'C:/Program Files (x86)/OpenSSL/include'  

created directory 'C:/Program Files (x86)/OpenSSL/include/openssl'  

Can't Open "./ms/applink.c" at .\util\copy.pl line 61.  

NMAKE : fatal error U1077: "C:\Perl\bin\perl.exe": return code "0x16"


-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mta.openssl.org/pipermail/openssl-users/attachments/20160921/b0051992/attachment.html>

More information about the openssl-users mailing list