[openssl-users] Failed to install OpenSSL 1.1.0 using 'nmake install'

Andrew Hartley andrew.hartley at taxcomputersystems.com
Wed Sep 21 12:54:58 UTC 2016

Your step (4) to me appears to be wrong.  If you are to install openssl to the following directory:

                C:\Program Files (x86)\OpenSSL\

then you need to do:

?  perl Configure VC-WIN32 -prefix=C:\Program Files (x86)\OpenSSL

When I build openSSL I use nasm, so after the above I do:

?  ms\do_nasm

?  nmake -a -f ms\nt.mak

?  nmake -f ms\nt.mak test

?  nmake -f ms\nt.mak install

Does that help at all?

From: openssl-users [mailto:openssl-users-bounces at openssl.org] On Behalf Of Jing Liu
Sent: 21 September 2016 13:35
To: openssl-users at openssl.org
Subject: [openssl-users] Failed to install OpenSSL 1.1.0 using 'nmake install'

I've tried all my best to solve this problem but failed. Can you help me?

- OS: Windows 10
- Perl: ActivePerl 5.12.2 build 1202
- Development environment: MS Visual Studio 2010 SP1
- OpenSSL version: OpenSSL 1.1.0

I tried to compile and install OpenSSL 1.1.0 according to the following steps:

1. decompressed OpenSSL 1.1.0 software package to directory "D:\openssl-1.1.0";
2. opened the "Visual Studio 2010 command prompt" window using an Administrator identity;
3. switched to the directory "D:\openssl-1.1.0";
4. D:\openssl-1.1.0> perl Configure VC-WIN32;
5. D:\openssl-1.1.0> nmake;
6. D:\openssl-1.1.0> nmake test;

> So far, all steps went smoothly, but ...

7. D:\openssl-1.1.0> nmake install;

Here, I got the following error and there was no file being copied to the destination directories even though those directories were successfully created.

    Microsoft (R) program maintenance utility 10.00.30319.01 copy right (C) Microsoft Corporation.All rights reserved.
*** Installing development files
created directory 'C:/Program Files (x86)/OpenSSL'
created directory 'C:/Program Files (x86)/OpenSSL/include'
created directory 'C:/Program Files (x86)/OpenSSL/include/openssl'
Can't Open "./ms/applink.c" at .\util\copy.pl line 61.
NMAKE : fatal error U1077: "C:\Perl\bin\perl.exe": return code "0x16"

Registered in England with company number 5347048 
Registered office at Centurion House, London Road, Staines-upon-Thames, TW18 4AX

This electronic message contains information from Tax Computer Systems Ltd (a wholly owned subsidiary of tax systems plc) which is confidential and may be privileged. The information is intended to be for the sole use of the individual(s) or entity to whom it is addressed. If you are not the intended recipient, be aware that any disclosure, copying, distribution or use of the contents of this information is prohibited. If you have received this electronic message in error, please notify the sender by telephone or e-mail (to the number or e-mail address above) immediately and destroy the message and all attached documents.

Reasonable care has been taken to ensure that this communication (and any attachments or hyperlinks contained within it) is free from computer viruses. No responsibility is accepted by taxsystemsplc and the recipient should carry out any appropriate virus checks.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mta.openssl.org/pipermail/openssl-users/attachments/20160921/d9e11676/attachment-0001.html>

More information about the openssl-users mailing list