[openssl-users] How to enable RC4 in OpenSSL 1.1.0c

Viktor Dukhovni openssl-users at dukhovni.org
Wed Jan 18 23:37:28 UTC 2017

On Wed, Jan 18, 2017 at 03:30:12PM -0800, Chris Clark wrote:

> I am trying to compile OpenSSL 1.1.0c for Visual Studio with the
> depreciated RC4 cipher enabled.

The "Configure" script includes embedded documentation for the
available options.

    # enable-weak-ssl-ciphers
    #               Enable weak ciphers that are disabled by default. This currently
    #               only includes RC4 based ciphers.

> I tried the following configure line:
> perl Configure VC-WIN64A enable-weak-ssl-ciphers enable-deprecated enable-rc4
> Once I compile, and I run "openssl cipher -v" it does not show any RC4 ciphers.
> Is there another parameter needed?

Which "openssl" command did you run and against which libraries?
Report the output of "openssl version -a".

> I would also like to know, is it possible to also enable the
> depreciated SSL3 ciphers?

Do you mean the ciphers or the protocol?  Many SSLv3 ciphers are
still needed for interoperable TLS 1.0/1.1/1.2


More information about the openssl-users mailing list