[openssl-users] OpenSSL 1.1.0 providing new OIDs to source code

Matthias Ballreich matthias.ballreich at outlook.de
Sat Jul 8 23:31:00 UTC 2017

Hi there,

i want to contribute some more OIDs. Therefore i added the OIDs inside the „Objects.txt“ inside /crypto/objects

Then i run these commands:
perl objects.pl objects.txt obj_mac.num ../../include/openssl/obj_mac.h
perl obj_dat.pl ../../include/openssl/obj_mac.h obj_dat.h
perl objxref.pl obj_mac.num obj_xref.txt > obj_xref.h

The files are generated / updated. Then i build the source which builds fine without any exceptions. Then i tried to use the generated NIDs in my Code. For test purposes i tried to print out the short and Long Name of my new oid with OBJ_nid2sn(MY_NID) and OBJ_nid2(MY_NID). But here it prints out an empty string.

When o try to use my NID with X509_get_ext_by_NID(cert, MY_NID, -1) the Output is -2.

So where is the Problem or what i’m doing wrong here? Thanks!
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mta.openssl.org/pipermail/openssl-users/attachments/20170708/701ac3dc/attachment.html>

More information about the openssl-users mailing list