[openssl-users] Build from source; library not found?

Hiran Chaudhuri hiran.chaudhuri at mail.de
Wed May 17 14:39:39 UTC 2017

Hi Richard.
   Thank you for the fast response. 

 Am 17-May-2017 15:40:27 +0200 schrieb levitte at openssl.org: 
The are two ways to handle this. One is with the usual setting of

 $ LD_LIBRARY_PATH=`pwd` ldd libssl.so.1.0.0 Yes, this seems to work. Somehow I'd like to avoid having to tell every user to use the correct settings.   
The other is, when you compile your application, to use
 -Wl,-rpath,/prefix/openssl/lib Where would these options typically go? One of the applications is curl, which worked when I set "LDFLAGS=-R/prefix/openssl/lib" when doing configure/make/make install in the curl build directory. One of the applications is Apache httpd, which seems to not work when doing the same. So I'd definitely try your suggestion.   
Incidently, I think that when you do this, you'll find that it finds
 your libraries all right:

 $ ldd /prefix/openssl/bin/openssl Now this is interesting. Yes, openssl can find both the libraries libssl and libcrypto. Would that imply that rpath is only a setting for application (executables) but not for shared libraries? In that case the test I tried would be totally meaningless.   Hiran
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mta.openssl.org/pipermail/openssl-users/attachments/20170517/8bbdc5bb/attachment.html>

More information about the openssl-users mailing list