[openssl-users] Need help with creating a server certificate

Neo meister neomeisterhax at gmail.com
Thu Aug 2 11:38:35 UTC 2018

I started the process of creating a chain of certificates from the root CA
down to a leaf certificate using openssl running on a debian vm. I
successfully created and verified the root cert, intermediate cert and
chain file. The issue I am having now is that when I go to create a leaf
cert to be used by the server it will not work for me. After generating the
key and and the CSR i use this command " *openssl* ca -config
path/to/config/folder/openssl.cnf -extensions server_cert -days 375 -notext
-md sha256 -in path/to/CSR/folder/www.testcert.com.csr.pem -out

After running this command I get the output "using configuration from

When I check the folder i told openssl to place the newly created cert in
it is not there. I have tried changing to a different output folder for the
new cert but I get the same result. Any idea what is going on?

The guide I have been using up until this point is at:
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mta.openssl.org/pipermail/openssl-users/attachments/20180802/c6484bb2/attachment.html>

More information about the openssl-users mailing list