[openssl-users] Need help with creating a server certificate

murugesh pitchaiah murugesh.pitchaiah at gmail.com
Fri Aug 3 05:32:18 UTC 2018


The command you used is the correct one to generate a cert from CSR.
Still certificate not generated means there may be some config issue.

You did not see any errors after the following line ?
using configuration from
> path/to/config/folder/openssl.cnf".

Also check if the file/path permissions are ok.

Murugesh P.

On 8/2/18, Neo meister <neomeisterhax at gmail.com> wrote:
> I started the process of creating a chain of certificates from the root CA
> down to a leaf certificate using openssl running on a debian vm. I
> successfully created and verified the root cert, intermediate cert and
> chain file. The issue I am having now is that when I go to create a leaf
> cert to be used by the server it will not work for me. After generating the
> key and and the CSR i use this command " *openssl* ca -config
> path/to/config/folder/openssl.cnf -extensions server_cert -days 375 -notext
> -md sha256 -in path/to/CSR/folder/www.testcert.com.csr.pem -out
> path/to/output/cert/folder/www.testcert.com.cert.pem".
> After running this command I get the output "using configuration from
> path/to/config/folder/openssl.cnf".
> When I check the folder i told openssl to place the newly created cert in
> it is not there. I have tried changing to a different output folder for the
> new cert but I get the same result. Any idea what is going on?
> The guide I have been using up until this point is at:
> https://jamielinux.com/docs/openssl-certificate-authority/create-the-root-pair.html

More information about the openssl-users mailing list