Where to copy custom openssl engine library in openssl 1.1.0

Swamy J-S swamy.j-s at in.abb.com
Thu Apr 25 08:36:04 UTC 2019

Hi, Thanks for reply. I have a doubt here. Which config file you are referring too? Is there any file called “config” which is already existing somewhere or should I create a dummy file called config?

Just now I created a dummy file “config” and added the details you sent in this file.

Also added “export OPENSSL_CONF=path_to_config” in /etc/environment file. And ran the command “openssl engine store -t -c”.
Still am getting same error as store not found when I run my application.

Thanks and Regards,

From: Dmitry Belyavsky <beldmit at gmail.com>
Sent: Thursday, April 25, 2019 1:44 PM
To: Swamy J-S <swamy.j-s at in.abb.com>
Cc: openssl-users at openssl.org
Subject: Re: Where to copy custom openssl engine library in openssl 1.1.0

CAUTION: This email originated from outside of the organization. Do not click links or open attachments unless you recognize the sender and know the content is safe.


You should load your engine via config file.

It may look like
openssl_conf = openssl_def

engines = engine_section

storeengine = store_section

engine_id = store
dynamic_path = /usr/local/lib/engines/storeengine.so

Your application should load the config file, the way it works is different for different versions.

On Thu, Apr 25, 2019 at 11:07 AM Swamy J-S <swamy.j-s at in.abb.com<mailto:swamy.j-s at in.abb.com>> wrote:

Am working in Ubuntu 18.04 with openssl 1.1.0g version. I built a custom openssl engine and now i want to use this engine instead of default openssl engine.

My engine library name is libstoreengine.so and i copied this to /usr/lib/x86_64-linux-gnu/openssl-1.0.0/engines/ path.

When i run my application the it says Store Engine not found. There is path issue here, am i copying the library in right path? I copied my library in /lib/x86_64-linux-gnu still am getting same error.

Please let me know the right path where i have to copy this engine?

Thanks and Regards,

SY, Dmitry Belyavsky
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mta.openssl.org/pipermail/openssl-users/attachments/20190425/e2b46c08/attachment-0001.html>

More information about the openssl-users mailing list