Link error with openssl-1.1.1-c on AIX

Bill Hallahan bill_hallahan at
Wed Jun 26 22:29:00 UTC 2019

To whom it may concern.

I am trying to build openssl-1.1.1-c on AIX using the xlc compiler.  I know Linux quite well, but only have passing knowledge of AIX.

This is the system. (The name is sanitized - I am paranoid about security).

bash-4.2$ uname -a
AIX sanitized 1 6 00CD1ECE4C00

I have found the c99 compiler and the xlc compiler seem to work best. The arguments produced by the following configuration command are not compatible with gcc.

   ./config -static no-ec no-mdc2 no-rc5 no-idea --openssldir=/path_sanitized

I would prefer to use the xlc compiler.

(I am still trying to figure out how to get the compiler version. "-V" does not work).

I was getting many linker errors, but I have fixed the Makefile to include certain libraries.  Now I just have one unresolved external, which is "ecp_nistz256_mul_mont".

This is the output of the link failure.

/usr/local/packages/vac_remote/9-sept2008/./usr/vac/bin/.orig/xlc: 1501-210 (W) command option t contains an incorrect subargument
ld: 0711-317 ERROR: Undefined symbol: .ecp_nistz256_mul_mont
ld: 0711-345 Use the -bloadmap or -bnoquiet option to obtain more information.
make[2]: *** [apps/openssl] Error 8
make[2]: Leaving directory `/scratch/bhallaha/view_storage/bhallaha_o2_19_18_1_ossl/reliaty/web/openssl-1.1.1c'

I see a perl script related to the needed module and a number of assembly language files, and I presume only one is for AIX.

I've tried adding  -DECP_NISTZ256_ASM to the compile lines, but I still get that unresolved external.

Does anyone know what I need to do?  I'll eventually figure this out, but I'd like this to work as soon as possible.


-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the openssl-users mailing list