Using (not building) openssl with mingw on Windows 10

Sergio NNX sfhacker at
Wed Mar 20 22:44:31 UTC 2019

>> I've been happily using the Shining Light 32-bit binaries with both
>> openssl 1.0 and 1.1 and mingw.

a) Where can we download OpenSSL binaries (x64) for Windows built with MinGW?
    [ ]

b) D:\Temp-Apps\OpenSSL-Win64\bin>openssl version -a

    OpenSSL 1.1.1b  26 Feb 2019
    built on: Wed Feb 27 02:30:51 2019 UTC
    platform: VC-WIN64A
    options:  bn(64,64) rc4(16x,int) des(long) idea(int) blowfish(ptr)
    OPENSSLDIR: "C:\Program Files\Common Files\SSL"
    ENGINESDIR: "C:\Program Files\OpenSSL\lib\engines-1_1"
    Seeding source: os-specific

     + Paths seem to be hardcoded

c) D:\Temp-Apps\OpenSSL-Win64\bin>openssl engine capi -v -t -post list_containers
    6840:error:25078067:DSO support routines:win32_load:could not load the shared library:crypto\dso\dso_win32.c:107:filename(C:\Program Files\OpenSSL\lib\engines-1_1\capi.dll)
    6840:error:25070067:DSO support routines:DSO_load:could not load the shared library:crypto\dso\dso_lib.c:162:
    6840:error:260B6084:engine routines:dynamic_load:dso not found:crypto\engine\eng_dyn.c:414:
    6840:error:2606A074:engine routines:ENGINE_by_id:no such engine:crypto\engine\eng_list.c:334:id=capi

d) Unable to find any .a file within the installation folder (D:\Temp-Apps\OpenSSL-Win64)

>> On a new machine, I tried the 64-bit binaries.  However, they're
>> missing the openssl/lib/mingw directory where the .a files resided.

> Getting back to this:

> I tried mingw linking against these

> "c:/program files/openssl64/lib/libcrypto.lib"
> "c:/program files/openssl64/lib/libssl.lib"

> but the gcc linker failed to find the openssl functions.

> Anyone have any ideas?

We have been using OpenSSL for Windows (x64) built with MinGW for a long time.

> openssl.exe version -a

    OpenSSL 1.1.1a  20 Nov 2018
    built on: Sat Feb 23 14:32:38 2019 UTC
    platform: mingw64
    options:  bn(64,64) rc4(16x,int) des(long) idea(int) blowfish(ptr)
    compiler: gcc.exe -m64 -DWINVER=0x0501 -D_WIN32_WINNT=0x0501 -D_WIN32_IE=0x0501 -DPTW32_STATIC_LIB -D__CLEANUP_C -m64 -O2 -pipe -mms-bitfields -fno-builtin -march=core2 -mtune=core2 -DL_ENDIAN -DOPENSSL_PIC -DOPENSSL_CPUID_OBJ -DOPENSSL_IA32_SSE2 -DOPENSSL_BN_ASM_MONT -DOPENSSL_BN_ASM_MONT5 -DOPENSSL_BN_ASM_GF2m -DSHA1_ASM -DSHA256_ASM -DSHA512_ASM -DKECCAK1600_ASM -DRC4_ASM -DMD5_ASM -DAES_ASM -DVPAES_ASM -DBSAES_ASM -DGHASH_ASM -DECP_NISTZ256_ASM -DX25519_ASM -DPADLOCK_ASM -DPOLY1305_ASM -DWINVER=0x0501 -D_WIN32_WINNT=0x0501 -D_WIN32_IE=0x0501 -DPTW32_STATIC_LIB -D__CLEANUP_C -DUNICODE -D_UNICODE -DWIN32_LEAN_AND_MEAN -DOPENSSL_SSL_CLIENT_ENGINE_AUTO=capi -DOPENSSL_CAPIENG_DIALOG -m64 -pipe -mms-bitfields -fno-builtin -march=core2 -mtune=core2 -D_MT -DZLIB -DNDEBUG -I/mingw/include
    ENGINESDIR: "\OpenSSL\lib\engines-1_1"
    Seeding source: os-specific

> openssl engine
    (rdrand) Intel RDRAND engine
    (dynamic) Dynamic engine loading support
    (padlock) VIA PadLock (no-RNG, no-ACE)
    (capi) CryptoAPI ENGINE

@Ken: this seems to be a quite old thread, but if you need either the include files or the .a files
      or both, we could email them to you.

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the openssl-users mailing list