Fw:Re:Re: Building openssl outside of the source tree" doesn't work well

dengwenbin_0301 dengwenbin_0301 at 126.com
Fri May 24 02:45:28 UTC 2019

I tried on openssl-1.1.1a and openssl-1.1.1b and they all have the same issue. I think it has something to do with my env. But i am not able to figure out what is the cause.


-------- Forwarding messages --------

From: "dengwenbin_0301" <dengwenbin_0301 at 126.com>
Date: 2019-05-22 09:40:19
To: "Richard Levitte" <levitte at openssl.org>
Subject: Re:Re: Building openssl outside of the source tree" doesn't work well

Thanks for your reply, Richard.

Yes,  the "-Iinclude -Iapps/include" is missing. I don't know why this happened. I attached the the configdata.pm and its dump. Please help have a check.

wdeng at pek-dliu4-u1:~/wenbindfiles/openssl/openssl/obj [master]$ git log -n 1
commit d3136af3c3905a730bd8fb44158aab36a2549d9b
Author: Richard Levitte <levitte at openssl.org>
Date:   Sat May 18 16:24:21 2019 -0700

    Configure: let platform->dsoext() default with platform->shlibextsimple()
    We still use '.so' as a last resort...
    Fixes #8950
    Reviewed-by: Tim Hudson <tjh at openssl.org>
    (Merged from https://github.com/openssl/openssl/pull/8951)

At 2019-05-21 11:47:14, "Richard Levitte" <levitte at openssl.org> wrote:
>On Tue, 21 May 2019 03:26:41 +0200,
>dengwenbin_0301 wrote:
>> wdeng at pek-dliu4-u1:~/wenbindfiles/openssl/openssl [master]$ cd obj/
>> wdeng at pek-dliu4-u1:~/wenbindfiles/openssl/openssl/obj [master]$ ../config
>> Operating system: x86_64-whatever-linux2
>> Configuring OpenSSL version 3.0.0-dev for target linux-x86_64
>> Using os-specific seed configuration
>> Creating configdata.pm
>> Creating Makefile
>> **********************************************************************
>> ***                                                                ***
>> ***   OpenSSL has been successfully configured                     ***
>> ***                                                                ***
>> ***   If you encounter a problem while building, please open an    ***
>> ***   issue on GitHub <https://github.com/openssl/openssl/issues> ; ***
>> ***   and include the output from the following command:           ***
>> ***                                                                ***
>> ***       perl configdata.pm --dump                                ***
>> ***                                                                ***
>> ***   (If you are new to OpenSSL, you might want to consult the    ***
>> ***   'Troubleshooting' section in the INSTALL file first)         ***
>> ***                                                                ***
>> **********************************************************************
>> wdeng:~/wenbindfiles/openssl/openssl/obj [master]$ make
>> make depend && make _all
>> make[1]: Entering directory '/folk/wdeng/wenbindfiles/openssl/openssl/obj'
>> make[1]: Leaving directory '/folk/wdeng/wenbindfiles/openssl/openssl/obj'
>> make[1]: Entering directory '/folk/wdeng/wenbindfiles/openssl/openssl/obj'
>> gcc   -fPIC -pthread -m64 -Wa,--noexecstack -Wall -O3 -DOPENSSL_USE_NODELETE -DL_ENDIAN
>> -DOPENSSLDIR="\"/usr/local/ssl\"" -DENGINESDIR="\"/usr/local/lib/engines-3\"" -DMODULESDIR="\"/usr
>> /local/lib/ossl-modules\"" -DNDEBUG  -MMD -MF apps/libapps-lib-app_rand.d.tmp -MT apps/
>> libapps-lib-app_rand.o -c -o apps/libapps-lib-app_rand.o ../apps/app_rand.c
>> ../apps/app_rand.c:10:18: fatal error: apps.h: No such file or directory
>> compilation terminated.
>> Makefile:826: recipe for target 'apps/libapps-lib-app_rand.o' failed
>> make[1]: *** [apps/libapps-lib-app_rand.o] Error 1
>> make[1]: Leaving directory '/folk/wdeng/wenbindfiles/openssl/openssl/obj'
>> Makefile:165: recipe for target 'all' failed
>> make: *** [all] Error 2
>I tried exactly that just now, exactly same 'obj' ubdirectory, and it
>works with no problem.
>Something I'm noticing from your command line is that all -I options
>that I expect to see there are gone.  This is what I expect (note that
>I go directly at the object file for demonstration purposes):
>    : ; make apps/libapps-lib-app_rand.o 
>    gcc  -I. -Iinclude -Iapps/include -I.. -I../include
>    -I../apps/include  -fPIC -pthread -m64 -Wa,--noexecstack -Wall -O3
>    -DX25519_ASM -DPOLY1305_ASM -DOPENSSLDIR="\"/usr/local/ssl\""
>    -DENGINESDIR="\"/usr/local/lib/engines-3\""
>    -DMODULESDIR="\"/usr/local/lib/ossl-modules\"" -DNDEBUG  -MMD -MF
>    apps/libapps-lib-app_rand.d.tmp -MT apps/libapps-lib-app_rand.o -c
>    -o apps/libapps-lib-app_rand.o ../apps/app_rand.c
>So the question is what happened to '-I. -Iinclude -Iapps/include
>-I.. -I../include -I../apps/include' in your build.
>I cannot say right now, but it might help if you show the output from
>'./configdata.pm --dump'
>Richard Levitte         levitte at openssl.org
>OpenSSL Project         http://www.openssl.org/~levitte/

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://mta.openssl.org/pipermail/openssl-users/attachments/20190524/cc2182ce/attachment-0001.html>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: configdata.pm
Type: application/octet-stream
Size: 746093 bytes
Desc: not available
URL: <https://mta.openssl.org/pipermail/openssl-users/attachments/20190524/cc2182ce/attachment-0002.obj>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: configdata.pm.dump
Type: application/octet-stream
Size: 7391 bytes
Desc: not available
URL: <https://mta.openssl.org/pipermail/openssl-users/attachments/20190524/cc2182ce/attachment-0003.obj>

More information about the openssl-users mailing list