Openssl 3.0.2- Build error - catgets_failed

Michael Wojcik Michael.Wojcik at
Wed Apr 20 13:26:08 UTC 2022

> From: openssl-users <openssl-users-bounces at> On Behalf Of Gaurav Mittal11
> Sent: Wednesday, 20 April, 2022 06:52

> ...
> as: "crypto/aes/aes-ia64.s", catgets_failed 2: catgets_failed 1052: catgets_failed - IDENT

A web search isn't turning anything up, but you probably tried that already.

I wonder if "catgets_failed" is a cryptic way of saying that as tried to retrieve message text from an NLS message catalog and failed, and it's just dumping parameters. What's your $LANG? Can you try the build with LANG set to C? Maybe make sure NLSPATH isn't set too?

(Someone at HP clearly didn't get the memo about emitting useful error messages. It's really not hard to wrap your message output to have a default string when the catalog lookup fails. Right up there in the list of Why Software Sucks, to use Platt's phrase.)

Michael Wojcik

More information about the openssl-users mailing list