Openssl 3.0.2- Build error - catgets_failed

Gaurav Mittal11 gaurav.mittal at
Thu Apr 21 15:54:39 UTC 2022

Yes, I have gone through internet search, I have not found any clue.

Still same error even after setting LANG to C

Yes, HP is kind of legacy server and very less help available on internet.

Any more suggestions would be helpful.

> echo NLSPATH
> echo $NLSPATH

> export LANG=C
> echo $LANG

export CC=/opt/aCC/bin/aCC
export CFLAGS="+DD64 -mt"
export CPPFLAGS="+DD64 -mt"
export LDFLAGS="-L/usr/lib/hpux64/"
export PATH=/usr/local/bin:/usr/contrib/imake/bin:$PATH
#./config --prefix=/opt/openssl/3.0.2 --openssldir=/opt/openssl/3.0.2 --shared hpux64-ia64-cc


Gaurav Mittal

-----Original Message-----
From: openssl-users <openssl-users-bounces at> On Behalf Of Michael Wojcik
Sent: 20 April 2022 06:56 PM
To: openssl-users at
Subject: [EXTERNAL] RE: Openssl 3.0.2- Build error - catgets_failed

> From: openssl-users <openssl-users-bounces at> On Behalf Of Gaurav Mittal11
> Sent: Wednesday, 20 April, 2022 06:52

> ...
> as: "crypto/aes/aes-ia64.s", catgets_failed 2: catgets_failed 1052: catgets_failed - IDENT

A web search isn't turning anything up, but you probably tried that already.

I wonder if "catgets_failed" is a cryptic way of saying that as tried to retrieve message text from an NLS message catalog and failed, and it's just dumping parameters. What's your $LANG? Can you try the build with LANG set to C? Maybe make sure NLSPATH isn't set too?

(Someone at HP clearly didn't get the memo about emitting useful error messages. It's really not hard to wrap your message output to have a default string when the catalog lookup fails. Right up there in the list of Why Software Sucks, to use Platt's phrase.)

Michael Wojcik

More information about the openssl-users mailing list