Openssl 3.0.2- Build error - catgets_failed

Michael Wojcik Michael.Wojcik at
Thu Apr 21 16:27:27 UTC 2022

> From: Gaurav Mittal11 <gaurav.mittal at>
> Sent: Thursday, 21 April, 2022 09:55
> Yes, I have gone through internet search, I have not found any clue.
> Still same error even after setting LANG to C
> Yes, HP is kind of legacy server and very less help available on internet.
> Any more suggestions would be helpful.

All I can say at the moment is that we haven't seen this with OpenSSL 1.1.1n on HP-UX 11i. We haven't tried building any 3.x versions on that platform yet (and maybe we won't have to, which would be great).

Can you post the failing .s file somewhere? Maybe looking at it will provide some clue. Those messages look like they might be syntax cascade errors, so it's possible the Perl script tossed something bogus in there.

We do have HP-UX assembler expertise here (in the compiler team, since we've had HP-UX support since the PA-RISC days at least, quite possibly since the 68K/FOCUS days) - not just Itanium experience, that is, but some working knowledge of the as program on that platform. I've battled through a bit of Itanium assembly now and then myself. So I may be able to find someone who can figure out where it's gone wrong.

Michael Wojcik

More information about the openssl-users mailing list