Openssl 3.0.2- Build error - catgets_failed

Gaurav Mittal11 gaurav.mittal at
Thu Apr 21 16:49:45 UTC 2022

I tried same commands and same setting with root access, seems like I pass that error.
Can you help why its not giving any error and not even generating crypto/chacha/libcrypto-lib-chacha-ia64.o  file

CC="/opt/aCC/bin/aCC" perl crypto/chacha/asm/ "void" -I. -Iinclude -Iproviders/common/include -Iproviders/implementations/include +Z -Ae +DD64 +Olit=all -z +DD64 -mt -DB_ENDIAN -DOPENSSL_PIC -DOPENSSLDIR="\"/opt/openssl/3.0.2\"" -DENGINESDIR="\"/opt/openssl/3.0.2/lib/hpux64/engines-3\"" -DMODULESDIR="\"/opt/openssl/3.0.2/lib/hpux64/ossl-modules\"" -D_REENTRANT -DOPENSSL_BUILDING_OPENSSL -D_XOPEN_SOURCE -D_XOPEN_SOURCE_EXTENDED -D_HPUX_ALT_XOPEN_SOCKET_API -DNDEBUG +DD64 -mt -DAES_ASM -DGHASH_ASM -DOPENSSL_CPUID_OBJ -DPOLY1305_ASM -DSHA1_ASM -DSHA256_ASM -DSHA512_ASM  crypto/chacha/chacha-ia64.S  ##This generate .S file

/opt/aCC/bin/aCC  -I. -Iinclude -Iproviders/common/include -Iproviders/implementations/include  -DAES_ASM -DGHASH_ASM -DOPENSSL_CPUID_OBJ -DPOLY1305_ASM -DSHA1_ASM -DSHA256_ASM -DSHA512_ASM +Z -Ae +DD64 +Olit=all -z +DD64 -mt -DB_ENDIAN -DOPENSSL_PIC -DOPENSSLDIR="\"/opt/openssl/3.0.2\"" -DENGINESDIR="\"/opt/openssl/3.0.2/lib/hpux64/engines-3\"" -DMODULESDIR="\"/opt/openssl/3.0.2/lib/hpux64/ossl-modules\"" -D_REENTRANT -DOPENSSL_BUILDING_OPENSSL -D_XOPEN_SOURCE -D_XOPEN_SOURCE_EXTENDED -D_HPUX_ALT_XOPEN_SOCKET_API -DNDEBUG +DD64 -mt -c -o crypto/chacha/libcrypto-lib-chacha-ia64.o crypto/chacha/chacha-ia64.S  ## this is not generating .o file

I have cut below command, it is trying to put all 100 .o file into one static librray and give error.

ar qc libcrypto.a crypto/aes/libcrypto-lib-aes-ia64.o crypto/aes/libcrypto-lib-aes_cbc.o crypto/cast/libcrypto-lib-c_skey.o crypto/chacha/libcrypto-lib-chacha-ia64.o

ar: could not open crypto/chacha/libcrypto-lib-chacha-ia64.o
gmake[1]: *** [Makefile:6800: libcrypto.a] Error 1
gmake[1]: Leaving directory '/home/infod3/tools/openssl-3.0.2'
gmake: *** [Makefile:1680: build_sw] Error 2

Gaurav Mittal

-----Original Message-----
From: openssl-users <openssl-users-bounces at> On Behalf Of Michael Wojcik
Sent: 21 April 2022 09:57 PM
To: openssl-users at
Subject: [EXTERNAL] RE: Openssl 3.0.2- Build error - catgets_failed

> From: Gaurav Mittal11 <gaurav.mittal at>
> Sent: Thursday, 21 April, 2022 09:55
> Yes, I have gone through internet search, I have not found any clue.
> Still same error even after setting LANG to C
> Yes, HP is kind of legacy server and very less help available on internet.
> Any more suggestions would be helpful.

All I can say at the moment is that we haven't seen this with OpenSSL 1.1.1n on HP-UX 11i. We haven't tried building any 3.x versions on that platform yet (and maybe we won't have to, which would be great).

Can you post the failing .s file somewhere? Maybe looking at it will provide some clue. Those messages look like they might be syntax cascade errors, so it's possible the Perl script tossed something bogus in there.

We do have HP-UX assembler expertise here (in the compiler team, since we've had HP-UX support since the PA-RISC days at least, quite possibly since the 68K/FOCUS days) - not just Itanium experience, that is, but some working knowledge of the as program on that platform. I've battled through a bit of Itanium assembly now and then myself. So I may be able to find someone who can figure out where it's gone wrong.

Michael Wojcik

More information about the openssl-users mailing list