Unable to load Legacy Provider

Gahlot, Ashish Kumar Ashish-Kumar.Gahlot at rbbn.com
Fri Apr 22 07:26:38 UTC 2022


I'm trying to load the Legacy Provider by following this guide here https://wiki.openssl.org/index.php/OpenSSL_3.0 using this following code:

/* Load Multiple providers into the default (NULL) library context */
       legacy = OSSL_PROVIDER_load(NULL, "legacy");
       if (legacy == NULL) {
           printf("Failed to load Legacy provider\n");
But it fails to load the legacy provider. I also tried to by editing the configuration file but I get the same error. I'm using "OpenSSL 3.0.0 7 sep 2021 (Library: OpenSSL 3.0.0 7 sep 2021)".

Thank you,

Notice: This e-mail together with any attachments may contain information of Ribbon Communications Inc. and its Affiliates that is confidential and/or proprietary for the sole use of the intended recipient. Any review, disclosure, reliance or distribution by others or forwarding without express permission is strictly prohibited. If you are not the intended recipient, please notify the sender immediately and then delete all copies, including any attachments.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://mta.openssl.org/pipermail/openssl-users/attachments/20220422/6342c654/attachment.htm>

More information about the openssl-users mailing list